51 votos

Android Studio Gradle BuildTools Revisión

Tengo un Proyecto Android en Android Studio 0.5.9 y Gradle es tirar este error:

Error:The SDK Build Tools revision (17.0.0) is too low. Minimum required is 19.0.0

Ya he instalado el SDK de Construir Herramientas de Revisión 19 desde el SDK Manager y aquí está mi generación.gradle

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.10.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.0"

    defaultConfig {
        minSdkVersion 9
        targetSdkVersion 17
    }

    sourceSets {
        main {
            manifest.srcFile 'Manantiales/src/main/AndroidManifest.xml'
        }
    }
}

¿Cómo puedo decirle a gradle para el uso de las Herramientas de Compilación 19 si ya está instalada?

EDIT: he marcado una respuesta diferente como La Mejor Respuesta porque fue el único que trabajó para la mayoría de la gente

74voto

Xexiz Puntos 476

Tuve el mismo problema esta mañana, después de la actualización .6.0. Usted necesita cambiar gradle versión en /nombreproyecto/construir.gradle

classpath 'com.android.tools.build:gradle:0.11.+'

Abrir el SDK manager y descargar la nueva versión de las herramientas de compilación 19.1 , a continuación, cambie la siguiente línea en /nombreproyecto/moduleName/construir.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

A continuación, sincronizar el gradle archivos y usted debe ser bueno para ir!

8voto

Azurai Puntos 87

Acabo de actualizar mi android studio para 0.6.0, y que me estaba dando el mismo problema. Pero mi compilación se 19.0.3, en lugar de 19.1.0. He cambiado el buildToolsVersion "19.0.3" -- > "19.1.0", que obligó a los Gradle para descargar las actualizaciones. He reiniciado mi Android Studio, y el error se fue. No estoy seguro exactamente de cómo explicar, pero creo que lo obliga a descargar el parche Maven sitio, y su justicia detrás de las escenas. Y así como Gabriel Matusevich, dijo, la construcción.gradle se encuentra ProjectFolder -> AppFolder -> build.gradle

Excepción: yo aun no completado probado esto, pero me di cuenta de la Gradle se ha descargado desde el sitio, yo aun no agregan o eliminan código, o ejecutó la aplicación todavía. Así que para estar seguro, recuerde que la buildToolsVersion número que tenía antes!

6voto

Jorge Vieira Puntos 69

Abierto Android SDK Manager y asegúrese de que tiene las Herramientas de generación 19.1 descargado. Doble verificación.

A continuación, encontrar construir/app.gradle y cambio buildToolsVersion número de '19.1':

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion '19.1'
    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19

    }

5voto

Mike Milla Puntos 168

He arreglado este problema va en myAppProject/actionbarsherlock/build.gradle y el cambio de

android {
    compileSdkVersion 14
    buildToolsVersion '17.0.0'

a este

android {
    compileSdkVersion 14
    buildToolsVersion '19.1.0'

1voto

He encontrado el problema, construir.gradle estaba en la carpeta equivocada

Iteramos.com

Iteramos es una comunidad de desarrolladores que busca expandir el conocimiento de la programación mas allá del inglés.
Tenemos una gran cantidad de contenido, y también puedes hacer tus propias preguntas o resolver las de los demás.

Powered by:

X