207 votos

Android Eclipse - No se pudo encontrar *.apk

Sé que esta pregunta se ha hecho antes y he visto una plétora de soluciones por ahí, sin embargo, ninguno parece funcionar para mí. Yo era capaz de construir mi apk sin problemas hasta que este error comenzó a surgir. He probado a limpiar mi proyecto, eliminándolo del espacio de trabajo y reimportándolo, eliminando "Java Builder" de mis Builders para el proyecto, construyendo el proyecto manualmente, reordenando mi ruta de construcción de java. No tengo problemas visibles con el compilador y no hay problemas en mi espacio de trabajo.

Ya experimenté este problema antes y lo resolví una vez eliminando el proyecto de mi espacio de trabajo y reimportándolo y otra vez lo resolví eliminando "Java Builder" de mi ruta de construcción de Java. Esta vez nada parece funcionar. Actualmente tengo la mayoría de los ajustes establecidos por defecto (es decir, la construcción de Java está marcada de nuevo).

Estoy ejecutando Windows 7 (64 bits) y utilizando jdk1.6.0_21 a través de Eclipse 3.6.

Cualquier sugerencia sería muy apreciada, ya que he perdido mucho tiempo de desarrollo solucionando este problema.

[Actualización] Mi configuración regional es el inglés y he intentado eliminar el debug.keystore, Estados Unidos como relacionado con número 834

605voto

Hikmat Khan Puntos 5173

Por favor, siga estos pasos; esto podría ayudarle:

  1. Haga clic con el botón derecho del ratón en su proyecto de aplicación y vaya a Propiedades

  2. Seleccione Android en la lista de la izquierda

  3. Desmarque la casilla "Es biblioteca".

Si su proyecto de aplicación se basa en proyectos de biblioteca que están en su espacio de trabajo, estos, por supuesto, deben tener la casilla "Es biblioteca" marcada.

24voto

gavtaylor Puntos 476

Borrar el archivo R.Java en la carpeta /Gen me ha funcionado

16voto

Elshaer Puntos 301

Probé todas las soluciones anteriores, pero no funcionaron.

¡¡¡¡¡¡¡La solución fue reiniciar eclipse !!!!!!!

espero que esto ayude a alguien :)

12voto

SHA1 Puntos 496

En mi caso este problema comenzó después de que Eclipse actualizara el plugin con la versión v4.0 de la API. Lo solucioné yendo a las preferencias principales de Eclipse y en Android->Build desmarcar 'Skip packaging and dexing until export or launch'.

Nota: si eclipse le da el error de comando desconocido 'crunch' entonces seguir este post

5voto

RoadRunner_23 Puntos 51

Elimine el proyecto de su espacio de trabajo y vuelva a importarlo.
Esto me ha funcionado.

No puedo creer que un tema similar haya estado ahí desde 2008.
http://code.google.com/p/Android/issues/detail?id=834 .

Iteramos.com

Iteramos es una comunidad de desarrolladores que busca expandir el conocimiento de la programación mas allá del inglés.
Tenemos una gran cantidad de contenido, y también puedes hacer tus propias preguntas o resolver las de los demás.

Powered by:

X