32 votos

No podía ' registro de t [...] con el servidor de arranque

Me sale este error al iniciar la aplicación en el Simulador de iOS:

Couldn't register com.mycompany.MyApp with the bootstrap server. Error: unknown error code.
This generally means that another instance of this process was already running or is hung in the debugger.

He leído otros informes de este error y parece que no hay obvia solución para él (reiniciar el Simulador de iOS, el reinicio de Xcode, etc..)

En este punto, he aquí una lista de cosas que he probado:

  • Reiniciar el Simulador
  • El Reinicio De Xcode
  • Reiniciar mi máquina
  • La eliminación de mi aplicación Derivada de los Datos, y la Limpieza
  • Borrar el Simulador de iOS de Soporte de la Aplicación del directorio de
  • Volviendo a una de las 2 semanas de edad la versión de la app (que estaba trabajando hace 2 semanas)
  • La eliminación de la aplicación en el Simulador (pulsando y sosteniendo en ella y golpear el botón X)
  • La actualización de Xcode formulario de la 4.1 a la 4.2, y la ejecución de la aplicación, tanto en el Simulador de iOS 4.3 y 5.0

Nada ha funcionado, me sigue apareciendo el mismo bootstrap error.. Alguna (y en este punto me refiero a CUALQUIER) sugerencia se agradece.

Edit: Sólo quería añadir que la aplicación funciona muy bien en un dispositivo. Solo obtengo este error en el simulador...

15voto

Kjuly Puntos 15089

Como el GDB dijo:

Esto generalmente significa que otra instancia de este proceso ya se estaba ejecutando o se cuelga en el depurador

Así que encontrarlo y matarlo. ;)
Me reinicia el mac, y que se ejecute con éxito.


Sugerencia: Bueno, esto no puede ser trabajo, a veces, así que me sugieren fuertemente que usted presione cmd+. para asegurarse de que usted tiene detenido el simulador (o dispositivo). Me parece que en la mayoría de los casos el simulador (o dispositivo) no va a parar exactamente cuando se bloquea. Yo rara vez se encontró con este problema de nuevo con la pulsación del cmd+. cada vez que se bloquea, o incluso de la salida normal. Espero que esto le sea útil. :)

11voto

Saif Puntos 1270

Cerraron mi xcode y reinicie mi device(ipad2) y funciona para mi :) Usted puede intentar esto:: Servidor de Bootstrap

2voto

Atwood Wong Puntos 41

Otra solución, vaya a borrar la memoria del iphone simulador simulador > contenido de recuperación y ajuste luego vuelva a ejecutar el programa.

1voto

Chelsea Wang Puntos 109

cambiar el identificador y la aplicación puede funcionar otra vez.

1voto

Simon Nilsson Puntos 11

Tuve este error demasiado y me di cuenta que funciona para mí si cerrar el simulador y detener el programa y luego cambiar su nombre de la empresa.

No sé por qué pero funciona para mí.

Iteramos.com

Iteramos es una comunidad de desarrolladores que busca expandir el conocimiento de la programación mas allá del inglés.
Tenemos una gran cantidad de contenido, y también puedes hacer tus propias preguntas o resolver las de los demás.

Powered by: