57 votos

ADT 22.3 (android 4.4) - error de "Después de la creación de la escena, #init() debe ser llamado"

Después de instalar el nuevo ADT (22.3.0.v201310242005-887826), que es compatible con Android 4.4 (kitkat), sigo recibiendo el error, como se muestra aquí:

enter image description here

Un interno se ha producido un error

en la lista de errores, veo varios elementos de "RenderPreview" , y cuando hago clic en cualquiera de ellos, veo:

Ha ocurrido un error interno. Después de la escena de la creación, #init() debe ser llamado

Cuando las pruebas de la nueva ADT en otro equipo, yo no puede ver este error, que aparecen allí. Esto es muy extraño.

¿Por qué obtengo los errores, y ¿qué puedo hacer para solucionarlo?

47voto

SimonSays Puntos 6467

He creado un Informe de fallo. Hasta que se arregle, establezca la versión API en la previa de la interfaz de usuario algo inferior a 19. El error sólo aparece para versión 19.

8voto

gku Puntos 81

Misma experiencia, pero un downgrade a 4.3 es para mí ahora sólo la exitosa solución temporal. Saludos cordiales Gku.

6voto

rishiPlus Puntos 72

Simplemente recorra de API de 19 a 18 API, la imagen de Android en el diseño gráfico

2voto

Rana.S Puntos 356

Es una solución temporal hasta que Google arreglado.

Solución: cambie a Android-18 en diseño gráfico (Android verde arriba-derecha).

Referencia: cómo solucionar Eclipse ADT Plugin 22,3 / SDK Tools 22,3 con rota ventana Propiedades?

1voto

Ann Puntos 212

Después de instalar el nuevo ADT (22.3.0.v201310242005-887826) que soporta Android 4.4 (kitkat), tengo el mismo error.

Luego ajuste la versión API en la previa de la interfaz de usuario algo inferior a 19. El error sólo aparece para versión 19.enter image description here

Iteramos.com

Iteramos es una comunidad de desarrolladores que busca expandir el conocimiento de la programación mas allá del inglés.
Tenemos una gran cantidad de contenido, y también puedes hacer tus propias preguntas o resolver las de los demás.

Powered by:

X